亚洲免费在线-亚洲免费在线播放-亚洲免费在线观看-亚洲免费在线观看视频-亚洲免费在线看-亚洲免费在线视频

Beans-hdu-2845

系統 2359 0


Beans

Time Limit: 2000/1000 MS (Java/Others)Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1977Accepted Submission(s): 997


Problem Description
Bean-eating is an interesting game, everyone owns an M*N matrix, which is filled with different qualities beans. Meantime, there is only one bean in any 1*1 grid. Now you want to eat the beans and collect the qualities, but everyone must obey by the following rules: if you eat the bean at the coordinate(x, y), you can’t eat the beans anyway at the coordinates listed (if exiting): (x, y-1), (x, y+1), and the both rows whose abscissas are x-1 and x+1.
Beans-hdu-2845

Now, how much qualities can you eat and then get ?

Input
There are a few cases. In each case, there are two integer M (row number) and N (column number). The next M lines each contain N integers, representing the qualities of the beans. We can make sure that the quality of bean isn't beyond 1000, and 1<=M*N<=200000.

Output
For each case, you just output the MAX qualities you can eat and then get.

Sample Input
      
4 6 11 0 7 5 13 9 78 4 81 6 22 4 1 40 9 34 16 10 11 22 0 33 39 6

Sample Output
      
242

重點: 橫豎分別求一下不連續的最大子段和;



    #include <iostream>
using namespace std;
int beans[100][100],line[100],row[100];
int main() {
	int m,n;
	while(cin >> m >> n){
		for(int i=0; i<m; i++){
			cin >> beans[i][0] >> beans[i][1];
			row[0] = beans[i][0];
			row[1] = beans[i][1];
			int tmpmax = max(row[0],row[1]);
			row[1] = tmpmax;
			for(int j=2; j<n; j++){
				cin >> beans[i][j];
				row[j] = max(row[j-2] + beans[i][j], row[j-1]);
			}
			line[i] = row[n-1];
		}
		int ans = max(line[0],line[1]);
		line[1] = ans;
		for(int i=2; i<m; i++){
			line[i] = max(line[i-2] + line[i], line[i-1]);
//			if(ans < line[i])
//				ans = line[i];
		}
		cout << line[m-1]  << endl;

	}
	return 0;
}
  




Beans-hdu-2845


更多文章、技術交流、商務合作、聯系博主

微信掃碼或搜索:z360901061

微信掃一掃加我為好友

QQ號聯系: 360901061

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描下面二維碼支持博主2元、5元、10元、20元等您想捐的金額吧,狠狠點擊下面給點支持吧,站長非常感激您!手機微信長按不能支付解決辦法:請將微信支付二維碼保存到相冊,切換到微信,然后點擊微信右上角掃一掃功能,選擇支付二維碼完成支付。

【本文對您有幫助就好】

您的支持是博主寫作最大的動力,如果您喜歡我的文章,感覺我的文章對您有幫助,請用微信掃描上面二維碼支持博主2元、5元、10元、自定義金額等您想捐的金額吧,站長會非常 感謝您的哦!!!

發表我的評論
最新評論 總共0條評論
主站蜘蛛池模板: 午夜性色吃奶添下面69影院 | 成人午夜毛片 | 国产精品永久免费 | 孕妇孕妇aaaaa级毛片视频 | 欧美a级成人淫片免费看 | 久久视频精品线视频在线网站 | 成人午夜视频在线播放 | sese视频在线 | 无遮挡一级毛片呦女视频 | 性做久久久久久免费观看 | 国产精品视频永久免费播放 | 国产精品第三页在线看 | 欧美区一区二 | 精品一区二区三区免费观看 | 国产精品久久久久久久久免费观看 | 奇米影视777狠狠狠888不卡 | 最新中文字幕在线播放 | 天天爱夜夜爽 | 男人天堂视频网 | 色婷婷99综合久久久精品 | 亚洲欧美日韩中文在线 | 国产片欧美片亚洲片久久综合 | 久久久久国产精品四虎 | 9299yy看片淫黄大片在线 | 国语一区 | 久久久久久久久性潮 | 色吧五月婷婷 | 天天做天天爱夜夜爽毛片毛片 | 91精品推荐 | 国产精品你懂的 | h片免费在线观看 | 国内精品福利视频 | 四虎影在永久在线观看 | 国产激情小视频 | 精品72久久久久久久中文字幕 | 中文字幕av在线 | 黄 色 免费网 站 成 人 | 国产伦精品一区二区三区免费观看 | 亚洲精品自产拍在线观看 | 四虎影院在线观看网站 | 奇米第四色在线观看 |